PROBLEM

Fernabfrage findet manchmal keine Voicemails wenn MS Exchange benutzt wird (kb4288)

Die Information in diesem Artikel betrifft die folgenden Produkte:

  • SwyxWare 2011
  • Microsoft Exchange 2010
  • SwyxWare v7.00
  • Microsoft Exchange 2007

[ Symptome | Ursache | Lösung | Status | Weitere Informationen ]


Symptome

Unter Umständen findet die Voicemail-Fernabfrage keine Voicemails, wenn man einen Microsoft Exchange Server 2007 oder 2010 verwendet.


Ursache

SwyxServer benutzt das IMAP4 Protokol, um beim Mailserver Voicemails im Posteingang des Benutzers zu suchen. Dazu wird eine Standard-IMAP-Suchanfrage gestartet, die nach EMails mit bestimmten Kopfzeilen sucht. Microsoft Exchange quitiiert diese Anfrage zwar positiv, liefert manchmal aber keine Ergebnisse, obwohl Voicemails im Posteingang vorhanden sind.


Lösung

Falls dieses Problem auftritt, können Sie SwyxServer mit folgendem Registry-Eintrag so einstellen, das er die Suchanfrage ohne das Kopfzeilen-Suchkriterium macht und danach selbst aus dem Suchergebnis Voicemails heraussucht:

Path HKLM\SOFTWARE[\Wow6432Node]\Swyx\IpPbxIMAP4\CurrentVersion\\Options
Type REG_DWORD
Name FetchOnlyVoicemails
Value 0
Description Wenn 0 benutzt IMAP eine Suchanfrage ohne nach spezifisachen "X-IpPbx…" Headerzeilen zu fragen.

Hinweis: Nach dieser Einstellung fragt SwyxServer bei jeder Fernabfrage die komplette Liste der EMails im Posteingang ab. Obwohl nur die Kopfzeilen und nicht der Inhalt abgefragt wird, kann es bei sehr vielen EMails im Posteingang zu Verzögerungen bei der Fernabfrage kommen.


Status

Workaround verfügbar. (siehe oben)

Weitere Informationen

Eine andere Ursache für dieses Problem kann auch die Exchange Header Firewall sein. Siehe Fernabfrage funktioniert unter Umständen nicht mit MS Exchange 2007 (kb4064)


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